Ticket #412 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

--without-lua doesn't disable lua

Reported by: anon Owned by: somebody
Priority: normal Milestone:
Component: component1 Version: 3.1
Severity: normal Keywords:
Cc:

Description

Hi,

trying to build pdns pdns-3.1-pre.20111206.2310 on Debian lenny. Configure:

./configure \
                CC="ccache gcc" CXX="ccache g++"\
                --prefix=/usr \
                --libexecdir='${prefix}/lib' \
                --libdir='${prefix}/lib/powerdns' \
                --sysconfdir=/etc/powerdns \
                --infodir='${datadir}/info' \
                --mandir='${datadir}/man' \
                --with-pgsql-lib=/opt/postgresql/lib --with-pgsql-includes=/opt/postgresql/include \
                --with-modules="gmysql pdns geo" \
                --with-dynmodules="" \
                --without-lua \
                --enable-static-binaries 

build breaks with first error:

libtool: link: ccache g++ -DSYSCONFDIR=\"/etc/powerdns\" -DLIBDIR=\"/usr/lib/powerdns\" -DLOCALSTATEDIR=\"/var/run\" -Ibackends/bind -pthread -Iext/polarssl/include -D_GNU_SOURCE -Wall -O2 -rdynamic -pthread -static -o dnsreplay dnsreplay.o misc.o qtype.o logger.o statbag.o dnspcap.o dnsparser.o dnsrecords.o rcpgenerator.o base64.o dnswriter.o dnslabeltext.o unix_utility.o sillyrecords.o nsecrecords.o base32.o  -L/usr/local/lib -lboost_program_options-mt -lz -pthread -Wl,-rpath -Wl,/usr/local/lib
lua-pdns-recursor.cc: In function 'bool netmaskMatchTable(lua_State*, const std::string&)':
lua-pdns-recursor.cc:66: error: 'lua_pushnil' was not declared in this scope
lua-pdns-recursor.cc:67: error: 'lua_next' was not declared in this scope

Change History

Changed 2 years ago by peter

  • status changed from new to closed
  • resolution set to fixed

Can reproduce with 2310; cannot reproduce with 2321 ( http://powerdnssec.org/downloads/pdns-3.1-pre.20111215.2321.tar.gz). Resolving as fixed :)

Note: See TracTickets for help on using tickets.